Apache Struts2 远程代码执行漏洞(CVE-2021-31805)风险提示

发布者:系统管理员发布时间:2022-04-14浏览次数:1

1、漏洞概述


近日,WebRAY安全服务产品线监测到Apache Struts官方发布Apache Struts2远程代码执行漏洞,漏洞编号为CVE-2021-31805。由于对CVE-2020-17530 ( S2-061 ) 的修复不完善,在某些标签属性中对用户的输入强制执行OGNL表达式时,可造成OGNL表达式二次解析,进一步导致远程代码执行。

Apache Struts2是一个用于开发Java EE网络应用程序的Web框架。在MVC设计模式中,Struts2作为控制器(Controller)来建立模型与视图的数据交互。

WebRAY安全服务产品线也将持续关注该漏洞进展,第一时间为您更新该漏洞信息。

2、影响范围


漏洞
编号
影响
产品
影响
版本
安全
版本
CVE-2021-31805
Apache Struts2
Struts 2.0.0 - Struts 2.5.29
2.5.30及更高

3、漏洞等级


WebRAY安全服务产品线风险评级:高危

4、修复建议


1、厂商已发布新版本,请及时更新Struts至2.5.30或更高版本。
下载地址:
https://cwiki.apache.org/confluence/display/WW/Version+Notes+2.5.30

2、如果目前无法升级,在业务环境允许的前提下,使用白名单限制访问web的ip来降低风险。

源自:盛邦安全WebRAY微信号